Dynamic doors opening the wrong way

Hi all,

I have been working on a house model.
I thought I had dynamic doors figured out, but this time around, they never seem to want to behave like they do in my model.

They are always opening the wrong way, or at the wrong angle. Is there something I am missing? I have been trying to figure this out for two hours now, but I can’t make any sense of what it’s doing.

Hi Kevin,

If the doors’ animation behaves differently in SketchUp and in VR Sketch, then it’s a bug. First check if you’re using the latest version (15.0). If you do, can you send me a small example where the behavior is different? Thanks! You can mail it to arigo@baroquesoftware.com. I should be able to fix it for the next release, but also tell you for what specific reason you’re running into this bug, so that you can work around it immediately.

Hi arigo!
Thanks for getting back to me so quickly
Here is a quick video I made, I think it does a good job of showing what I’ve been experiencing.
Google drive link

Additional information:
The doors are the same, they were only mirrored.

Thanks again,

Edit: I am using version 14! Let me update real quick and take a look again.
Edit 2: Exact same result with V15.0


Hi! Thank you for sending me the skp file.

The problem turned out to be the mirroring. If a component is mirrored in some way then the rotations are turning in the wrong direction in VR Sketch. I’ve fixed it for the next version (and hopefully didn’t break any other case by doing so).

I could build and post a link to a beta version of VR Sketch 15.1, so that you can see the door fixed and maybe test it with other animated components that you have. Are you interested? Do you need the PC or the Oculus Quest version?


Thank you so much for the rapid response.

I would gladly test the Beta 15.1

I would be testing on my Oculus Quest 2

Here you are: https://vrsketch.eu/download/baroquesoftware_vrsketch_v15.1.0-BETA3.apk

Hi again! Sorry for the delay, I have just finished testing, and so far, everything works good. Thank you so much for the quick fix!


Just an update:
Is scale supposed to be supported as far as animations go?

Thanks again,

No, no animated scaling is supported at the moment.