Feature Request. Viewer orientation

With the default “Position Camera” tool in SketchUp you can Click and drag to set the Camera Orientation.


I wish I could do that with the “VR Sketch tool” to orient my client correctly when placing them in the model.


Problem Explained here:

Hi! Sorry for the delay.

Thanks for the request! It looks like a good idea to let the orientation be easily changed from Sketchup. VRSketch was originally designed with the idea that the person in VR would be standing and turning around freely, and forcing turns can be confusing in this case. But that argument doesn’t really work in all cases. I’ll try to add dragging-to-change-the-orientation to our “VR Sketch Tool”.

Thats great. You’re correct in assuming that the default should maintain the current orientation. However, some clients, particularly those not accustomed to VR, prefer the seated position and then turning can pose a challenge. Providing the option to set their orientation before teleporting can be a practical.

Done! It will be in the next release. I can also send you a preview if you want (do you need the standalone Quest version or is the PC VR version enough?).

Here is the in-progress version for PC VR with this and a few other changes:

It’s not really tested so I hope there are no other problems. Changes
from 19.0.0:

  • due to a bug, point clouds were recentered around the origin. Now
    the original position is kept. If you already made models around
    recentered point clouds, you can still get the old behavior with a
    checkbox in the “View point cloud…” dialog box.

  • in Sketchup, with the VR Sketch Tool, we can now optionally control
    the orientation we want to teleport the VR user to (use
    click-and-drag). If you just click, then like before it teleports the
    VR user without changing his or her orientation.

  • Bug fix: when we click on a scene in Sketchup, the VR user would no
    longer automatically go to the same position. Fixed.

  • On the new Quest 3, you can enable a passthrough mode where the
    depth of the real-world room is taken into account. It is called
    “Passthrough: room depth” in the Rendering settings. In this mode, if
    you enlarge or move the virtual model so that parts of it are farther
    than the real walls, then these parts fade out. You still see them,
    but as if your real walls were only a little bit transparent.

Sorry for being such a terrible user for not testing this sooner. Just updated to v21 and it work just as I hoped. Thank you so much for this!