Freehand move broken in 15.0? Also, undo issue?

Just did some routine stuff, noticed that VR Sketch is behaving very strangely. Restarting PC made no difference.

I move object as normal with the freehand tool. However, it often (20-60% of the time) immediately jumps back to original place. I try again. This time, the movement is applied twice so it moves much further than intended. In other words, it appears that the movement did happen, but was not registered until I poked the object again. Also, the undo-redo arrows are gone for some reason.

I checked and can confirm that the object has moved correctly in SketchUp.
(I’ve only tried with freehand, could be with regular move tool)


(there is a confusing moment where the a another stick suddenly appears, this is because I moved it earlier, but it failed to move until the second stick was moved)

I can add: The undo button appears once I open and close a group. But all the other actions - move, scale, freehand draw, notes, do not appear there, only undo/redo open group.

Also, it’s not an issue with freehand, the same problem happens with scale, regular move etc - object jump back to original place, then jump “forth” again later.

(On a sidenote, the new freehand lock to plane is amazing! Unfortunately the “note” lock to plane is not, I accidentally lock onto a surface all the time by accident as freehand notes are usually done over existing geometry. I would prefer to have this lock unto surface feature be removed, or made optional)

I cannot reproduce your problems. In SketchUp 2018 running baroquesoftware_vrsketch_v15.0.1.rbz, or in SketchUp 2020 running the latest development version, on both PC and Quest, moving groups and undo work as it always has for me. Could you send me the exact model you are using? (And point me to the exact group you’re trying to move, but I guess I can find it from the video.)

Sorry for the large filesize (wetransfer) - I purged the file, removing a bunch of hidden layers and the large textures to get the filesize down to 40mb. Then I did a check, and the issue was gone. Not sure if this helps explaining where the issue is. Screenshot shows example of object I moved that most of the time does not move at once. (Perhaps this is related to the issue of objects taking very long time to move at my end, in previous versions of VR sketch)

I’ve been trying but my system runs out of main memory, with VR Sketch consuming 14 GB of RAM at some point during loading. Maybe the issue for you is also related to an out-of-memory situation. If that’s the case, though, I’m unsure about why neither you nor me (via automatic bug reporting) is getting any error. But it’s possible that out-of-memory manifest in various ways including silently aborting the current operation. It could theoretically occur after SketchUp moved the object and while it’s trying to send the updated geometry to VR Sketch, with either side running out of memory at the wrong time, and any reporting it tries to do ends up failing because… no memory.

Can you check in the Windows task manager, sorting by the column “Memory”, how much memory is used by both SketchUp and VR Sketch?

If I manually turn off sending all textures from SketchUp to VR Sketch, the model loads fine and the group from the screenshot moves without problem for me (I tried moving it around a lot).

Can you try ? It reduces the maximum texture size from 16384 to 8192. The 10000-wide textures from your model get scaled. It seems to reduce the main memory usage (I’m not sure why, it should only have a major impact on the GPU memory). Moreover it reduces it by more than 4x (I’m really not sure why). It loads fine for me now and moving the now-textured group around still works fine.

Sorry for late reply! Thank you, I will try this as soon as I can

I just realized that I forgot to respond to this, sorry!! I tried the version you sent (15.1.0) and the problem was completely gone. Perfect, and thank you!