Issue using VR Sketch and Quest

We are trying to use VR Sketch via SketchUp Make 2017 and VR Sketch 14.0.0 with a client who is considering bying a full license. I have uploaded a model to the cloud, and the client wants to download the moden in the Quest to walk around.

We have followed all the steps (afaik) correctly, including developer mode, installing VR Sketch through “Sidequest” etc.
We have successfully launched VR Sketch in the Quest using Sidequest (using a cable, Sidequest doesn’t seem to work with wifi). Apparently the user sees a building interior/warehouse (presumably the default VR sketch home environment) and the following text:
“VR Sketch - Send your model from SketchUp”
“cloud models - quest ID nr xxxxxx”

However, at this point, the user loses control. The app is running, controllers are shown in correct position etc. But the user is no longer able to click on anything.

After a while in the a “connection error” message apparently appears, but the users can still see the controllers in correction location etc

Maybe reading between the lines, the user “looses control” as in “he tries to click but it has never got any effect”? Is he maybe expecting the dialog box to work by point-and-click at a distance? Because in that case, indeed, he won’t manage to click. He needs to move the controller on the dialog box, very close to it. A “mouse” cursor should appear just beyond the controller on the dialog box, when he is close enough.

Thank you, I will ask the client to try this. (Unfortunately communication across Teams wasn’t great, we could not see what he saw in VR and have access neither to the quest nor to mac to test for ourselves)

I haven’t confirmed this with the client yet but I suspect this message could be the reason why we couldn’t move on after many difficult steps to install VR sketch on a mac with quest over Teams. I downloaded the latest version to test myself just now, and noticed this message floating high over me as I entered VR Sketch. I could barely reach the “got it” button by stretching high. No idea why it appeared so high up in the room, but this was certainly not intuitive.

Indeed, that’s bad. I have no clue why it appeared so high for you. Maybe the headset reported a bogus position at the exact point where VR Sketch started. I’ll clamp the height so that it never shows up too high.

The client confirmed that this is what he saw, and could not reach the text box as the cable from the laptop was too short. Mystery solved then I guess.

Once the client is past this point, should he then able to type in the 9 digit code to download our cloud model directly from within the Quest?

I’m still not sure what your client really saw, because the dialog box you described and that I fixed should appear only after he picks a model to display (e.g. by entering the 9-digits code). Maybe the dialog box that he happened to see high in the air was actually the one in which the 9-digits code must be entered. He should just try again, because I have never got any dialog box high in the air. I still guess it occur depending on what the headset happens to report as head and controller position a just the wrong time.

I will try to see if I can meaningfully clamp the height of all dialog boxes (not as easy as it sounds because some of them appear in front of others, and moving that up or down arbitrarily might suddenly shift it behind the dialog box it’s supposed to be in front of…)