Issues loading Cloud Models

Hey there, I have been having issues loading cloud models. I just get this…

Nothing really happens. Has worked for me flawlessly in the past.

Hi! Sorry for the delay. It seems that there is a problem that makes the upload empty (0.00 MB). I don’t know what is going wrong a priori. There is one automated error report that might be related. Can you tell me your Windows user name? It shows up in paths, C:\Users\XXX, so I could check. Please reply either here or as a private message if you prefer to keep this information non-public.

I am a mac user. Not sure if there is other information needed?

OK, so that’s not it. Can you open the Ruby console (Window menu), and then try again to upload your model, to see if some error appears there?

This is all I got, nothing really.

SOLUTION: wouldn’t even load then the internet completely quit on me. Rebooted everything, computer, Sketchup etc and everything worked like a charm… FACEPALM not sure why and how it did this because internet worked everywhere else…
Thanks again.