PCVR issue in 21.0 - controller tracking and visual artifacts

I’m having issues with VR Sketch (send to VR on this PC mode) losing controller tracking if I pop the headset up to look at monitor for a moment (even for 1 second), its seems very inconsistent as to whether it regains the controllers. Head movement is unaffected.

Same thing happens if I toggle using the Oculus / Meta button and then straight back into VrSketch, seem random whether I get the controllers back in VrSketch

This same action also introduces uncomfortable visual artifacts in the right eye only.
I can only describe it as a tracking or rendering latency in a checkerboard pattern within a portion of the right eye image covering a variable right hand and bottom portion of the right eye. It reports running at 72fps locked
The same model is fine when sent to Quest and running on the headset, I have also tried it with other models and the same issues are manifest.

If I peek and replace the headset a number of times, occasionally the artifacts will not appear and everything is buttery smooth. Its a well, evenly lit room

Quest 3
SU Pro 2024
VR Sketch 21
Windows 11


Hi Rob,

Sadly, it looks like a problem which is outside our immediate control. I didn’t see it myself, but I’ve heard about it already. I have no idea what is causing it because “it works for me”—I’m mostly testing VR Sketch on hardware and software similar to yours (Quest 3, VR Sketch 21, Windows 11, 4070; different version of SU but that shouldn’t matter here).

As a workaround, you could try stuffing a folded piece of paper inside your headset, above the eyes, above covering the sensor: the goal is to make the headset think your head is always inside it, and completely avoid all the turning off-and-back-on operations.

If I happen to see the problem myself, I will investigate and see what I can find.

In case you want to help, you could try running older versions of VR Sketch and see if they have the same problem. That would help us know if it was caused by a change we control (something in the version of Unity we’re using or the Oculus’ software parts inside Unity), or not (an update of the Quest, or of the Meta Link application on PC).

Armin Rigo

Sorry, I meant the piece paper should be above the eyes but of course covering the sensor, not above it.

Thanks Armin.

Will earlier versions work with SU 24?
I said have a few perf issues with VR Sketch 20 (PCVR) on SU 2023 which going back to VR Sketch 19 entirely solved.
One of the only reasons I use the PCVR versions is when I want screen record a walkthrough, as the PC has the compute overhead, whereas it affects performance when recording natively on the Quest app.

As an aside, VR Sketch performs so well natively on Quest 3, I even run it at 150% resolution at 90Hz via Quest Game Optimiser. The visuals look so good, you have an awesome app here, I’ve used a ton of viewers from various vendors and intermediate architectural collaboration apps and VR Sketch beats them all hands down. I do all my main work on MacOS so having that easy connection is just great. Thank-you

Ah right: no, older versions of VR Sketch won’t work with Sketchup 2024. You need to check older versions of VR Sketch with Sketchup <= 2023, but it shouldn’t have an impact on the primary issues you describe.

Can you check if running now VR Sketch 19 as well as 20 works, or if it shows the same controllers and right-eye problems? Your message didn’t make it clear if VR Sketch 19 or 20 runs fine now (ignoring the unrelated perf issues), or if they only did so in the past—in the latter case, please try again, because anything else on your PC might have changed in the meantime.

[I would describe PC VR as quite a messy stack of half-bogus software, honestly. Sometimes you even need to reboot your computer and headset in order for an unexpected problem to disappear. Or semi-automatic updates in the software stack cause issues.]

Also, quick check: what occurs if you don’t regain the controllers after quickly taking off the headset? Does pressing a button on the controller wake it up again, or is that not sufficient?

Right, no. No input at all, the oculus button is the only thing that works and toggles in and out of the app. Out of the app everything is functional.

So I understand. I follow a few XR developers on Twitter and the frustrations are apparent.

I will do some experimenting

Can you try the following version? It should be the same as 21.0.0 but with hand tracking disabled. Maybe this helps:


will do, thanks, will test later

Hi Armin, just to let you know, that build sorts out the controller input issues, all works fine now, thanks.
Visual artifacts still there (I realise this build was not addressing that issue)
Performance seems smoother as well, getting around 90 fps with the same model (although that could have been related to a restart but I’ll take the win)

Is there a chance that you are using an old version of the Meta Quest Link (previously Oculus Link) application on your PC? I’m not sure it is reasonable for you, but is there a chance you could try to uninstall and reinstall it?

I’m asking because I realized that the change I made to the NOHANDS.rbz file above has no effect to any of the internal logic; it just changes the “manifest”, which is a file that is not used by VR Sketch. Instead, I believe it is passed around and processed by the Meta Quest Link application. That means that we cannot make a checkbox inside VR Sketch to enable to disable hand tracking, because that setting needs to be built into the “manifest” file.

So I’m suspecting—hoping?—that the difference between your setup and mine is that you have an old version of Meta Quest Link. This is both about the controllers and about the visual glitch.

Meta Quest Link app version (

Ah, mine says Runtime version: Version So you may have a more recent version than me… Let me check

No, can’t update past version 65. In the Meta Quest Link app, Parameters, Beta tab, did you check “Public test channel”?

Probably. Im on the PTC for standalone so I guess its a cross platform option

Ah, OK. That’s actually documented in our docs:

“”“Note: do not subscribe to the Oculus Public Test Channel. Your Quest would be updated to a more recent version of the firmware than the one we can test with: we did not manage to subscribe ourselves so far. It would mean that you could get new bugs related to a firmware version that we cannot run.”""

So we can’t do more than guess that the two issues you have are related to the newer version of the apps that we cannot run ourselves. Hopefully the NOHANDS version above is good enough in your case. We’ll of course come back to that issue if the problem is still present when Meta switches the PTC version to the main version. (In fact, I don’t know how the Test channel works, but maybe you can send them a bug report about this? But probably not, guessing how Meta generally works.)

Fair enough. I’ll stick with NOHANDS for now, thanks :+1:
The visual artefacts don’t show up in the OBS capture as I think it defaults to capturing the left eye anyway (which doesn’t exhibit the artefacts) so thats good enough for me.