PNG Textures Appearing Translucent

I recently had an encounter with another person in VR via the Oculus Quest 2 and VR Sketch where PNG textures were appearing translucent to them but not to me. I was hosting the model and all PNG textures rendered correctly on my end but for him, the entire surface appeared semi-opaque? Do you know of a setting or bug that might be causing this?

I would like to believe that team members or clients are seeing the same thing I am when I share a model but now I am not sure that is always the case?

Thank you for your time.

No, this looks like a bug of some kind. There should be only one setting that influences how the model is rendered, but it shouldn’t make textures translucent or not: it’s in the Settings dialog box, Options page, “Performance trade-off”. I would first check, if you open this dialog and toggle this setting, if the textures are suddenly translucent or opaque. There are a few other options in this page and in the Rendering page, but they should not have an effect on textures.

Do both you and the other person use Oculus Quest 2? Do you use the exact same version of VR Sketch? If possible, can you send me ( the model where the problem occurs, or some simplified version of it—maybe down to one face with the problematic material on it?

Mystery solved! It was the “Performance trade-off” setting! Thank you so much! I will know in future to tell visitors to check that setting if and when they experience this effect with the PNG textures rendering translucent!

Many thanks!

I’m glad you could figure it out! I would still be very interested in learning more about it. Is there any chance that you could send me a model with just one face of the problematic material? Thank you if that is possible!