Real floor is above the VR one

Hi! I just started using the VR Sketch Oculus app and noticed that after teleporting a real floor is above VR one. So if I put the controller on the physical floor and draw a rect, it will be at ~56mm above that face I teleported to.

Is it configurable somewhere or is it a bug?


This is most likely your floor level being misconfigured in your VR headset. You need to redo the guardian setup (the exact name depends on your headset; in SteamVR it is called the “Room Setup”). VR Sketch, like most other VR programs, assumes that the guardian was correctly set up in the headset before, along with the floor level, and so they don’t offer a specific way to tweak that.

Armin Rigo

1 Like

I use Oculus Quest 2 with safety borders off. Have enabled it and VR Sketch shows a floor correct now. Thank you!

Ah, I see. Yes, it’s usually the same procedure to set both the floor height and the guardian safety borders. But you still need to do it even if you don’t use the guardian, otherwise the floor height is wrong :slight_smile: