Valve Index Controllers

I’m using a Valve Index with the Index controllers. I may be missing something but I can’t seem to get any bindings to work. VRSketch seems to default to Oculus controllers and I don’t see a way to change that inside of VRSketch. I’ve tried a few different things inside of SteamVR attempting to get it to work, to no avail, is there a way to set the controller in VRSketch to Index controller?

Hi! It seems that people are having problems with newer versions. Can you try version 17.0.4 and/or version 17.0.8? Ideally 17.0.8 first, and if it doesn’t help, try 17.0.4. We’d like to hear about which version broke the support for Valve Index.

Version 17.0.8 works perfectly. Thanks for the links!

VR Sketch 17.0.9 is made with a more recent version of Unity and an upgraded internal SteamVR package. I bet one of the two is the cause. We can’t easily debug it because we don’t have access to Knuckles controllers right now, and it seems to work fine with other SteamVR-based headsets…

One thing you could try is to go to the small SteamVR
window (the black one which shows the status of your headset and
controllers). Go into the SteamVR menu, “Device”, “Controller
settings”. “Controllers”, “Manage controller bindings”, pick the app
“VR Sketch” (which must be running), select “Custom”, “Edit this
binding”. At least I think that’s how you do it at the moment; it changed
a lot recently. The bindings available should have names that come
from VR Sketch (like “Open tool selection”) and they can be assigned
to buttons. As far as I can tell, this assignment should already be
OK, but I have no way to see that page without having the real
controllers (which, if you ask me, is a stupid design decision). If you
can improve the situation by making tweaks in that page, that would
be interesting feedback for us.

If you have a moment, would you mind checking if the following pre-release version helps? It may or may not have fixed the problem; we’re a bit in the dark about it.