Problem loading point clouds

Hello, I’m running version 16.0 on an Oculus Quest 2 and windows pc. I’ve been trying to use the new point cloud feature. I downloaded some sample point clouds and converted them to Potree format as described in the guide. I used Potree Converter 1.7. However, when I load the cloud.js files into vr sketch, they all show up as a spaced out grid of black points (see image below). The program also gets very laggy.

It’s hard to see them in the above image. Below, I’ve shrunk the scale so the grid is clustered around my controller:

I’m quite confused. I tried opening the cloud.js file in Potree Desktop and it looks fine:

Any idea what might be going wrong? And a side question, is the point cloud tool compatible with Potree Converter 2.0 and newer versions?


Hi Alex,

Could you try with the version of POTreeConverter we link to? It’s 1.6.

Please tell us if it works. If it does, we’ll need to document that version 1.6 is recommended (or investigate what changed). We didn’t try to run a more recent version. Of course, it’s quite possible that it won’t work either. In that case, could we have an example file? Maybe VRSketch is somehow confused by the format of your files…

Armin Rigo

Hi Armin. I recreated the files with potree 1.6 and it worked! Just to confirm, I consistently get the black dot grid when switching to the same file made with 1.7. I can send you two example files created in 1.6 and 1.7 if you like. How could I send you zipped folders?

Thanks for your help

Hi! For now I’ve simply written in the docs that potree 1.6 is needed. We might investigate later, but it’s really a side-feature of VR Sketch and if potree 1.6 works fine then there isn’t really much point. If you experience other problems with it, though, we’d like to hear about it!

Ok thanks! I do have another issue but I’m not sure if it’s a bug or a feature. The program says the point size is forced to 0 on quest, which I understand. But when I use a link cable with my quest 2 for PCVR, the points still only show up if I set them to size 0. Is this normal?

As an aside, I think point cloud support is an extremely powerful feature of VR Sketch, especially for architectural work in adaptive reuse and historic conservation. Personally, the ability to model with point clouds in VR is a dream come true. I’d be thrilled to see this functionality expanded in the future, like some of the stuff you can do with the Scan Essentials extension.

Thanks again

Hi again,

You’re right, I just tested a point cloud with a nonzero point size and I see nothing like you do. I guess something broke recently. Sorry about that, I’ll investigate.

As you can tell, point cloud support is more of an add-on than a real core feature of VR Sketch, so far, and not very well tested. But we might at some point develop it more. Thanks for the Scan Essentials link. Particularly interesting to try to reproduce in VR: it seems to have “Direct modeling” capabilities. At least we could add snap-to-point easily, but I guess there is a lot more things we could do, starting with the ability to move/rotate/scale the point cloud to fit the model instead of the other way around.


Should be fixed. Here is the current development version if you want to give it a try:

1 Like

This works great, thanks a lot. I have a side question. Is it possible to view a point cloud within a cloud model with multiple users collaborating? Would each user have to import the point cloud separately, on their own machines, to see it?

Yes, it should work in collaborative mode. This is again something that wasn’t very deeply tested but I did test it once and at that time it worked. Only the person who exposes his model for others to see can add a point cloud to it. Upon doing so, the point cloud should become visible inside everybody’s headsets. (This is the same logic than the one that displays the point cloud inside a standalone Oculus Quest: in both cases the point cloud is incrementally sent over an internet connection.)

1 Like

We have tested point clouds in collaborative mode… and they don’t work. Sorry about that. We are fixing the problems now. It might require you to install the upcoming release 17 of VR Sketch (not yet out, but very soon).