Rhino viewer (pre-alpha)

Hi all,

We are investigating if some kind of Rhino support would be doable. We made an alpha view-only version of VR Sketch for Rhino. Would somebody be interested in testing it? Most importantly, we’d be interested in getting some biggish native Rhino models in order to test and debug it. If you are interested to help, please contact us at info@baroquesoftware.com . (We will of course treat any model you’d share with us confidentially.)


Armin Rigo

1 Like

The early beta version for Rhino 7 (for PC VR only) is now available via Rhino’s package manager!

You need to start Rhino 7, go to Tools -> Package Manager, and search for VRSketchRhino.

It contains only viewing, no editing; even edits done in Rhino are not automatically sent over to VR right now.

The plugin was updated to work with standalone Quests (and Pico Neo 3 when we finish VR Sketch 19 for that platform). See the release announcement.

Hi! Absolutely loving this plugin, thanks so much. It works flawlessly for me so far. I’m running into an issue, where every time I want to turn off the plugin and just use rhino… I take off the goggles, I close the VRSketch window by clicking the x at the top corner, Rhino notes that it was cleanly disconnected… and then rhino crashes about 20 seconds later, happens every time in rhino 7 and 8. Any suggestions? Maybe a better way to close it out?
Thanks again, excellent work

Hi, thanks for the feedback!

Sorry about the issue, we’ll try to investigate if we can reproduce it on our side. In the meantime, the best might be to close Rhino before it crashes, and starts it again?

Armin Rigo

I just tried the Rhino viewer, and it worked well. Some questions, though:

  1. What’s the monetization plan here?
  2. Any plans to show Rhino layers and allow them to be switched on or off?
  3. Is there a section view tool?
  4. Can you rotate something freely? I displayed a small handheld item and I wasn’t able to change its orientation.
  5. Shadow sliders didn’t seem to do much. Can you enable cast shadows from the sun, and/or ambient occlusion?
  6. Any plans to skip SteamVR and implement straight OpenXR? (I’m using a HP Reverb G2 which doesn’t need SteamVR.)

Hi @eobet,

  1. We have not decided yet what the monetization plan should be. The current viewer is definitely a small part only of all the editing capabilities you get for Sketchup.

  2. Not yet. We’ll write it down on our to-do list.

  3. I’d need to check, but I think that the “Section Plane” tool should work (I think it’s above the Tape Measure tool).

  4. Yes, you can rotate and scale and move the model. Use the “grip” button on the side of both controllers at the same time, and move your hands apart or turn them.

  5. I’d need to check (sorry, we’re mostly off until January). It’s probably because of the previous point: you need the model to be not small before the shadows are clearly visible. We also have ambient occlusion (but only on PC, not with the standalone Quest or Pico Neo 3) which probably suffers from a similar scale issue.

  6. We have no such plans at the moment. We don’t directly support the HP Reverb. Note that if something I described above doesn’t work, it might be because we don’t support the controllers. Maybe you can convince SteamVR to remap the controller buttons in that case. Sorry about that, we had to pick which headsets and particularly controllers to support…

Hi @Michael4190,

Sorry for the delay. I’ve found what the problem was, and hopefully fixed it in the version 0.19.3 just released now (on food4rhino or in the built-in package manager). It crashed as soon as you edited your model after you closed the VR connection. This new version should be properly shutting down now.

Thanks again for reporting the problem,

Armin Rigo

Right on! Thank you so much for your time on this, excellent. If you have more time to kill I found another one, when I set up a scene, get the model going etc, and then take my oculus quest 3 goggles off and hand them to another person to view it, the simulated hand remotes get stuck in the floor. It looks kind of like they jump to a 0,0,0 coordinate and I can’t pick them up again. I’m using the googles with the airlink and no wire, just using oculus software not steam VR. It seems clear that Oculus root software hasn’t lost the remotes, if I back out to a menu or something the Oculus sim remotes are there, but when I jump back into your app, they are stuck in the floor still. We found a work around, if I keep taking the physical remotes outside the boundary and then back in again over and over again sometimes it like resets it and the simulated remotes come back to my hands, but its tricky. Now I just have a sticky note inside my quest 3 goggles so it never thinks that I took them off ha. Thanks again for your time, really happy about this plugin!!

Another one for you if it seems relevant: I have a few images applied as textures in Rhino… I use a projection map to scale and place the image in the right spot. VRsketch does a good job importing and applying those images, but it loses the placement and scaling data from my projection. It just kind of scales the entire image to fit the object and it looks all off. Thanks again!!

Thanks a lot for all your comments and suggestions!

About the Quest controllers jumping back to 0,0,0: we’ll look into it more—thanks for providing a way that seems to reproduce the issue. I hope we can fix it or at least work around it inside VR Sketch. At this point it seems to be a problem in the Oculus-provided Unity integration package.

About the images applied as textures: I thought I got textures showing up at the right position, but maybe you are using a different way to show images as textures. Ideally, could you send us a small Rhino file with just one object, where the texture position is wrong in VR? Thanks! (You can send it to info@baroquesoftware.com)

The texture position is sometimes wrong in Rhino 8, but seems correct in Rhino 7. This might be a deliberate or accidental change in Rhino 8. We have tested with Rhino 7 so far; thanks for pointing out this difference.

The texture position is fixed in the new VR Sketch 20.0 and the corresponding Rhino plugin 0.20.0. This release also shows the correct layers only—the ones shown in Rhino at the moment.

Hello there!
Thank you all for the amazing plugin you are building for Rhino.
I’ve installed and tried it today with a Quest 2 and I am very impressed.

There are a couple of things that are not working properly, at least with Rhino 7:

  • material Transparency: I’ve tried all the materials (Glass, Gem, Custom, Physically Based…) but none seems to send the transparency to VR Sketch. I’ve also checked if Opacity would do the job. Is there a way to implement it? (or… am I doing something wrong?)

  • reflections: it would be great to have some… is it possible?

  • VR Sketch crashed when I clicked on “Audio” settings

Overall, I would like to thank you again for this plugin.
It is friendly, looks good and it is smooth and clean. Thank you.

Hi! Thanks for the comments!

  • material transparency: indeed, I only tried with basic colors and opaque textures. I will need to check with a few kinds of material and if possible make them keep their transparency.

  • real reflections are very difficult to do in real-time rendering, particularly in systems like ours that don’t include a lengthy preprocessing step. There are workarounds where the surfaces can be realistically more or less smooth, and more or less metallic, but where the light reflected on the surface comes from the sky (even in interior spaces). It’s already done in this way—e.g. the light on the ground has a blueish tint that comes from the sky. But the smoothness and metallicity are constants. They could be copied from Rhino instead.

  • “Audio” settings: I’ll check if I can reproduce that. Which platform are you running VR Sketch on—is that on the Quest 2 standalone as installed via the Meta Quest App Lab page, or is that on the PC via Oculus Link / Air Link?

1 Like

Hi again,

The transparency was a quick fix: I’ve uploaded the version 0.20.1, for now to the Package Manager (install via Rhino’s Tools menu, Package Manager, type “vrsketch”).

Note that I’m seeing some differences in the way Rhino draws, say, a cube with a transparent material. In VR Sketch, both the front and the back faces are drawn. In Rhino apparently only the front faces are drawn. I suspect this difference to be important in many cases, e.g. a thin window may incorrectly be drawn twice in VR Sketch, once for each side. Still need to investigate.

Armin Rigo

1 Like

Thank you for the quick answer! I am going to try the new version this evening.

Regarding the Audio crash… I was using Quest 2 standalone via the Meta Quest App.
It happened twice, with different models.
I don’t know if it was loading something very heavy and I should have waited more, but the screen froze for a couple of minutes so I forced the app to quit. :-/

Thank you again for your support!

Ah, you denied access to the microphone, right? I never tested this case as I thought VR Sketch would just get silence. It turns out it crashes instead. Argh.

1 Like

Oh yes, that’s true I denied the microphone! I thought I wouldn’t have never use it in the app :sweat_smile:

No problem!

About the transparency issues I thought I found previously: I might have been wrong, it seems now in my tests that Rhino draws both sides of a box with a transparent material. I’m not sure if there is a Rhino way in which this can be avoided (maybe it depends on which exact material you’re using, or which exact kind of object it is).

I also found out that you can give sub-objects their own materials (e.g. each face of a box, with ctrl-shift-click). VR Sketch doesn’t know that so far, so all faces of that box will be drawn with the same object-wide material. I’ll write it down on our “fix me” list.

There are so many poorly documented subtleties to keep in mind; I think there is no way to comprehensively implement it. All we can do is fix any such issues as they are found. Thanks a lot for reporting some of them!

Armin Rigo

1 Like