Tools not active


I’m a new member of the community and a BIG fan of the app’s capabilities. I’ve got the student license and I’m having problems with all of my models (and demos). All of my tools are without icons and described as “not active”. Is it some kind of programming issue or that form of license doesn’t allow to edit models inside VR?


In Sketchup, you have to use one of the first three commands in the VR Sketch menu (or the first tree buttons in the toolbar). If you use “Upload file to cloud” instead, then you are getting a snapshot, i.e. a read-only cloud copy of your model, and cannot edit it. The point of that command is that you can still view the model at any later time. But for direct connection including editing, choose “Send to VR” or “Collaborative editing”.

We’re always interested in improving the user interface. If that was helpful, could you tell us how we could have made that clearer? Would it have helped with one line of explanation inside the “Upload file to cloud” dialog box?

If you are instead not using Sketchup but our Rhino demo, then indeed that version doesn’t support any editing from VR. VR Sketch is a view-only tool on Rhino. To allow editing for Rhino we would have to support a much larger set of tools; that’s not planned for now.

Armin Rigo

Thanks a lot Armin! That’s exactly what I experienced. I’m using the Sketchup version. I chose upload to cloud as it was quick and easy - the loading screen was helpful to see the process. When I tried the “send to VR” option it froze my pc and crashed the oculus app (the file is ~300Mb). I’ll try again after work with more patience :slight_smile:
As for improvements - the dialog box would be great and made clear or as an extra step in the tutorial.
It would help a ton if you could make a loading screen when choosing the “send to VR” option (that would show if the process is updating

We attempted to have progress shown in Sketchup; however, it’s difficult for technical reasons. It would not be fully impossible; I’ve added it on our to-do list. Note that you can already see the progress (or lack thereof) in the headset.

More to the point, there are indeed some network configurations which seem to stall progress of the “send to VR” option after a while. We didn’t manage to understand why so far, nor why the “upload to cloud” solution works more often.

I tried “send to vr” a few times yesterday without success. The thing I didn’t mention is that the option I choose is “send to oculus”, not the pc version. I created a new file with a simple block and it worked great with the ability to edit the model. I think my main file is just too big for the process - it would crash all of Sketchup to the point where I was forced to force close the program. Any advice here?

But it worked by uploading the model to the cloud, and then downloading the model and viewing it on the Quest? That’s unexpected… Maybe you are in a network with a strange firewall? Though even that explanation isn’t really one if uploading the model to the cloud works.

When you do a direct connection, after you enter the 6-digits number on the PC but before you click “GO”, does it say “local wifi connection” or “encrypted connection via the cloud”?

Note that Sketchup seems to hang for a while when sending the model; that’s normal. You need to check in the headset itself to see if there is still progress. Also, if you go to the headset and forcefully quit the VR Sketch app, it should give feedback to Sketchup and make it responsive again—unless the connection between the two was really hanging elsewhere for technical reasons.